summaryrefslogtreecommitdiffstats
path: root/plugins/55/wrap.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel@debian.org>2024-12-01 21:17:14 +0100
committerDaniel Baumann <daniel@debian.org>2024-12-12 11:27:45 +0100
commitbf596cbb426bd672a46484bca3bd07cfa6662919 (patch)
tree41ef466309f3e567f63e8e68ef272b0a4e214138 /plugins/55/wrap.mk
parentInitial commit. (diff)
downloaddokuwiki-plugins-extra-bf596cbb426bd672a46484bca3bd07cfa6662919.tar.xz
dokuwiki-plugins-extra-bf596cbb426bd672a46484bca3bd07cfa6662919.zip
Adding upstream version 20241201.upstream/20241201upstream
Signed-off-by: Daniel Baumann <daniel@debian.org>
Diffstat (limited to 'plugins/55/wrap.mk')
-rw-r--r--plugins/55/wrap.mk57
1 files changed, 57 insertions, 0 deletions
diff --git a/plugins/55/wrap.mk b/plugins/55/wrap.mk
new file mode 100644
index 0000000..af03726
--- /dev/null
+++ b/plugins/55/wrap.mk
@@ -0,0 +1,57 @@
+# Progress Linux: dokuwiki-plugins-extra
+
+# Copyright (C) 2024 Daniel Baumann <daniel.baumann@progress-linux.org>
+#
+# SPDX-License-Identifier: GPL-3.0+
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+# Build-Depends:
+# none
+
+SHELL := sh -e
+
+PLUGIN := wrap
+
+all:
+
+test:
+
+build:
+
+install:
+ mkdir -p $(DESTDIR)/usr/share/dokuwiki/plugins-extra
+ cp -a $(PLUGIN) $(DESTDIR)/usr/share/dokuwiki/plugins-extra
+
+ # removing unused files
+ rm -f $(DESTDIR)/usr/share/dokuwiki/plugins-extra/$(PLUGIN)/README*
+ rm -rf $(DESTDIR)/usr/share/dokuwiki/plugins-extra/$(PLUGIN)/.git*
+
+ rm -f $(DESTDIR)/usr/share/dokuwiki/plugins-extra/$(PLUGIN)/COPYING*
+ rm -rf $(DESTDIR)/usr/share/dokuwiki/plugins-extra/$(PLUGIN)/_test
+
+uninstall:
+ rm -rf $(DESTDIR)/usr/share/dokuwiki/plugins-extra/$(PLUGIN)
+ rmdir --ignore-fail-on-non-empty --parents $(DESTDIR) || true
+
+clean:
+
+distclean:
+
+reinstall: uninstall install
+
+upstream:
+ rm -rf $(PLUGIN)
+ git clone https://github.com/selfthinker/dokuwiki_plugin_wrap $(PLUGIN)
+ rm -rf $(PLUGIN)/.git