summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel@debian.org>2024-10-14 12:12:29 +0200
committerDaniel Baumann <daniel@debian.org>2024-10-14 12:12:29 +0200
commitd4669509709f9e62e4f26f49969f83122f58f12a (patch)
treee5f2f46573bfe785b8bbf31c0bd04b8f9a61a03e /Makefile
parentInitial commit. (diff)
downloadfastforward-packages-upstream.tar.xz
fastforward-packages-upstream.zip
Adding upstream version 20241014.upstream/20241014upstream
Signed-off-by: Daniel Baumann <daniel@debian.org>
Diffstat (limited to '')
-rw-r--r--Makefile112
1 files changed, 112 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..3b8e17a
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,112 @@
+# Copyright (C) 2004-2024 Daniel Baumann <daniel@debian.org>
+#
+# SPDX-License-Identifier: GPL-3.0+
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+SHELL := sh -e
+
+PROJECT := fastforward-packages
+SOFTWARE := fastforward-packages
+
+VERSION := $(shell cat VERSION.txt)
+
+all: build
+
+clean: clean-pgp
+
+clean-pgp:
+ # clean pgp keyrings
+ rm -f pgp-keys/*/*.gpg
+ rm -f pgp-keys/*.gpg
+
+build: build-pgp
+
+build-pgp: pgp-keys/*/*.pub
+ # build pgp keyrings
+ for KEY in $$(ls pgp-keys/*/*.pub); \
+ do \
+ OUTPUT="$$(dirname $${KEY})/$$(basename $${KEY} .pub).gpg"; \
+ echo "Creating $${OUTPUT}..."; \
+ gpg --output $${OUTPUT} --dearmor $${KEY}; \
+ done
+
+ for DIRECTORY in $$(ls -d pgp-keys/*/); \
+ do \
+ OUTPUT="pgp-keys/$$(basename $${DIRECTORY}).gpg"; \
+ echo "Creating $${OUTPUT}..."; \
+ for KEY in $$(ls $${DIRECTORY}/*.gpg); \
+ do \
+ cat $${KEY} >> $${OUTPUT}; \
+ done; \
+ done
+
+test: test-pgp
+
+test-pgp: pgp-keys/*/*.sign
+ # test pgp keyrings
+ for SIG in $$(ls pgp-keys/*/*.sign); \
+ do \
+ echo "Verifying $${SIG}..."; \
+ gpg --no-default-keyring --keyring /usr/share/keyrings/debian-keyring.gpg --keyring /usr/share/keyrings/debian-maintainers.gpg --verify $${SIG}; \
+ done
+
+install: install-doc install-pgp
+
+install-doc:
+ # install doc
+ mkdir -p $(DESTDIR)/usr/share/doc/$(SOFTWARE)
+ cp *.txt $(DESTDIR)/usr/share/doc/$(SOFTWARE)
+
+install-pgp: build-pgp
+ # install pgp keyrings
+ mkdir -p $(DESTDIR)/usr/share/$(SOFTWARE)/pgp-keys
+ cp pgp-keys/*.gpg $(DESTDIR)/usr/share/$(SOFTWARE)/pgp-keys
+
+uninstall: uninstall-doc uninstall-pgp
+
+uninstall-doc:
+ # uninstall doc
+ rm -rf $(DESTDIR)/usr/share/doc/$(SOFTWARE)
+
+uninstall-pgp:
+ # uninstall pgp keyrings
+ rm -rf $(DESTDIR)/usr/share/$(SOFTWARE)/pgp-keys
+ -rmdir --parents $(DESTDIR)/usr/share/$(SOFTWARE)
+
+reinstall: clean uninstall build install
+
+distclean: clean
+ rm -rf $(SOFTWARE)-$(VERSION)
+
+release: distclean
+ git commit -a -s -S -m 'Releasing version $(VERSION).' || true
+ git tag -s -m 'Tagging version $(VERSION).' v$(VERSION) || true
+
+ mkdir -p $(SOFTWARE)-$(VERSION)
+ find . -mindepth 1 -maxdepth 1 -and -not -name ".git*" -and -not -name debian -and -not -name $(SOFTWARE)-$(VERSION) -exec cp \-a {} $(SOFTWARE)-$(VERSION) \;
+
+ for FORMAT in xz; \
+ do \
+ EXTENSION=$$(echo $${FORMAT} | cut -b-2); \
+ tar --$${FORMAT} -cf ../$(SOFTWARE)-$(VERSION).tar.$${EXTENSION} $(SOFTWARE)-$(VERSION); \
+ sha512sum ../$(SOFTWARE)-$(VERSION).tar.$${EXTENSION} > ../$(SOFTWARE)-$(VERSION).tar.$${EXTENSION}.sha512; \
+ gpg --default-key 0xE184321652A10838 --armor -b ../$(SOFTWARE)-$(VERSION).tar.$${EXTENSION}; \
+ mv ../$(SOFTWARE)-$(VERSION).tar.$${EXTENSION}.asc ../$(SOFTWARE)-$(VERSION).tar.$${EXTENSION}.sign; \
+ done
+
+ rm -rf $(SOFTWARE)-$(VERSION)
+
+upload:
+ scp ../$(SOFTWARE)-$(VERSION).* apt.$(PROJECT).org:/srv/apt.$(PROJECT).org/archive/upstream/$(SOFTWARE)