summaryrefslogtreecommitdiffstats
path: root/options/gitignore/R
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--options/gitignore/R49
-rw-r--r--options/gitignore/ROS51
-rw-r--r--options/gitignore/ROS229
-rw-r--r--options/gitignore/Racket15
-rw-r--r--options/gitignore/Rails69
-rw-r--r--options/gitignore/Raku7
-rw-r--r--options/gitignore/ReScript3
-rw-r--r--options/gitignore/Red16
-rw-r--r--options/gitignore/Redcar1
-rw-r--r--options/gitignore/Redis3
-rw-r--r--options/gitignore/RhodesRhomobile9
-rw-r--r--options/gitignore/Ruby56
-rw-r--r--options/gitignore/Rust21
13 files changed, 329 insertions, 0 deletions
diff --git a/options/gitignore/R b/options/gitignore/R
new file mode 100644
index 0000000..e75435c
--- /dev/null
+++ b/options/gitignore/R
@@ -0,0 +1,49 @@
+# History files
+.Rhistory
+.Rapp.history
+
+# Session Data files
+.RData
+.RDataTmp
+
+# User-specific files
+.Ruserdata
+
+# Example code in package build process
+*-Ex.R
+
+# Output files from R CMD build
+/*.tar.gz
+
+# Output files from R CMD check
+/*.Rcheck/
+
+# RStudio files
+.Rproj.user/
+
+# produced vignettes
+vignettes/*.html
+vignettes/*.pdf
+
+# OAuth2 token, see https://github.com/hadley/httr/releases/tag/v0.3
+.httr-oauth
+
+# knitr and R markdown default cache directories
+*_cache/
+/cache/
+
+# Temporary files created by R markdown
+*.utf8.md
+*.knit.md
+
+# R Environment Variables
+.Renviron
+
+# pkgdown site
+docs/
+
+# translation temp files
+po/*~
+
+# RStudio Connect folder
+rsconnect/
diff --git a/options/gitignore/ROS b/options/gitignore/ROS
new file mode 100644
index 0000000..35d74bb
--- /dev/null
+++ b/options/gitignore/ROS
@@ -0,0 +1,51 @@
+devel/
+logs/
+build/
+bin/
+lib/
+msg_gen/
+srv_gen/
+msg/*Action.msg
+msg/*ActionFeedback.msg
+msg/*ActionGoal.msg
+msg/*ActionResult.msg
+msg/*Feedback.msg
+msg/*Goal.msg
+msg/*Result.msg
+msg/_*.py
+build_isolated/
+devel_isolated/
+
+# Generated by dynamic reconfigure
+*.cfgc
+/cfg/cpp/
+/cfg/*.py
+
+# Ignore generated docs
+*.dox
+*.wikidoc
+
+# eclipse stuff
+.project
+.cproject
+
+# qcreator stuff
+CMakeLists.txt.user
+
+srv/_*.py
+*.pcd
+*.pyc
+qtcreator-*
+*.user
+
+/planning/cfg
+/planning/docs
+/planning/src
+
+*~
+
+# Emacs
+.#*
+
+# Catkin custom files
+CATKIN_IGNORE
diff --git a/options/gitignore/ROS2 b/options/gitignore/ROS2
new file mode 100644
index 0000000..6cc824d
--- /dev/null
+++ b/options/gitignore/ROS2
@@ -0,0 +1,29 @@
+install/
+log/
+build/
+
+# Ignore generated docs
+*.dox
+*.wikidoc
+
+# eclipse stuff
+.project
+.cproject
+
+# qcreator stuff
+CMakeLists.txt.user
+
+srv/_*.py
+*.pcd
+*.pyc
+qtcreator-*
+*.user
+
+*~
+
+# Emacs
+.#*
+
+# Colcon custom files
+COLCON_IGNORE
+AMENT_IGNORE
diff --git a/options/gitignore/Racket b/options/gitignore/Racket
new file mode 100644
index 0000000..962478a
--- /dev/null
+++ b/options/gitignore/Racket
@@ -0,0 +1,15 @@
+# gitignore template for the Racket language
+# website: http://www.racket-lang.org/
+
+# DrRacket autosave files
+*.rkt~
+*.rkt.bak
+\#*.rkt#
+\#*.rkt#*#
+
+# Compiled racket bytecode
+compiled/
+*.zo
+
+# Dependency tracking files
+*.dep
diff --git a/options/gitignore/Rails b/options/gitignore/Rails
new file mode 100644
index 0000000..c55bb71
--- /dev/null
+++ b/options/gitignore/Rails
@@ -0,0 +1,69 @@
+*.rbc
+capybara-*.html
+.rspec
+/db/*.sqlite3
+/db/*.sqlite3-journal
+/db/*.sqlite3-[0-9]*
+/public/system
+/coverage/
+/spec/tmp
+*.orig
+rerun.txt
+pickle-email-*.html
+
+# Ignore all logfiles and tempfiles.
+/log/*
+/tmp/*
+!/log/.keep
+!/tmp/.keep
+
+# TODO Comment out this rule if you are OK with secrets being uploaded to the repo
+config/initializers/secret_token.rb
+config/master.key
+
+# Only include if you have production secrets in this file, which is no longer a Rails default
+# config/secrets.yml
+
+# dotenv, dotenv-rails
+# TODO Comment out these rules if environment variables can be committed
+.env
+.env*.local
+
+## Environment normalization:
+/.bundle
+/vendor/bundle
+
+# these should all be checked in to normalize the environment:
+# Gemfile.lock, .ruby-version, .ruby-gemset
+
+# unless supporting rvm < 1.11.0 or doing something fancy, ignore this:
+.rvmrc
+
+# if using bower-rails ignore default bower_components path bower.json files
+/vendor/assets/bower_components
+*.bowerrc
+bower.json
+
+# Ignore pow environment settings
+.powenv
+
+# Ignore Byebug command history file.
+.byebug_history
+
+# Ignore node_modules
+node_modules/
+
+# Ignore precompiled javascript packs
+/public/packs
+/public/packs-test
+/public/assets
+
+# Ignore yarn files
+/yarn-error.log
+yarn-debug.log*
+.yarn-integrity
+
+# Ignore uploaded files in development
+/storage/*
+!/storage/.keep
+/public/uploads
diff --git a/options/gitignore/Raku b/options/gitignore/Raku
new file mode 100644
index 0000000..e792f6e
--- /dev/null
+++ b/options/gitignore/Raku
@@ -0,0 +1,7 @@
+# Gitignore for Raku (https://raku.org)
+# As part of https://github.com/github/gitignore
+
+# precompiled files
+.precomp
+lib/.precomp
+
diff --git a/options/gitignore/ReScript b/options/gitignore/ReScript
new file mode 100644
index 0000000..b7364c9
--- /dev/null
+++ b/options/gitignore/ReScript
@@ -0,0 +1,3 @@
+/node_modules/
+/lib/
+.bsb.lock
diff --git a/options/gitignore/Red b/options/gitignore/Red
new file mode 100644
index 0000000..b78a06f
--- /dev/null
+++ b/options/gitignore/Red
@@ -0,0 +1,16 @@
+# gitignore template for Red programming language
+# website: http://www.red-lang.org/
+
+# Red Compiled code
+*.red
+
+# Libraries
+crush.dll
+crush.dylib
+crush.so
+
+# Files generated during test
+quick-test/quick-test.log
+quick-test/runnable/
+system/tests/source/units/auto-tests/
+tests/source/units/auto-tests/
diff --git a/options/gitignore/Redcar b/options/gitignore/Redcar
new file mode 100644
index 0000000..b4a9d1d
--- /dev/null
+++ b/options/gitignore/Redcar
@@ -0,0 +1 @@
+.redcar
diff --git a/options/gitignore/Redis b/options/gitignore/Redis
new file mode 100644
index 0000000..57c1c23
--- /dev/null
+++ b/options/gitignore/Redis
@@ -0,0 +1,3 @@
+# Ignore redis binary dump (dump.rdb) files
+
+*.rdb
diff --git a/options/gitignore/RhodesRhomobile b/options/gitignore/RhodesRhomobile
new file mode 100644
index 0000000..a211dcc
--- /dev/null
+++ b/options/gitignore/RhodesRhomobile
@@ -0,0 +1,9 @@
+rholog-*
+sim-*
+bin/libs
+bin/RhoBundle
+bin/tmp
+bin/target
+bin/*.ap_
+*.o
+*.jar
diff --git a/options/gitignore/Ruby b/options/gitignore/Ruby
new file mode 100644
index 0000000..e3200e0
--- /dev/null
+++ b/options/gitignore/Ruby
@@ -0,0 +1,56 @@
+*.gem
+*.rbc
+/.config
+/coverage/
+/InstalledFiles
+/pkg/
+/spec/reports/
+/spec/examples.txt
+/test/tmp/
+/test/version_tmp/
+/tmp/
+
+# Used by dotenv library to load environment variables.
+# .env
+
+# Ignore Byebug command history file.
+.byebug_history
+
+## Specific to RubyMotion:
+.dat*
+.repl_history
+build/
+*.bridgesupport
+build-iPhoneOS/
+build-iPhoneSimulator/
+
+## Specific to RubyMotion (use of CocoaPods):
+#
+# We recommend against adding the Pods directory to your .gitignore. However
+# you should judge for yourself, the pros and cons are mentioned at:
+# https://guides.cocoapods.org/using/using-cocoapods.html#should-i-check-the-pods-directory-into-source-control
+#
+# vendor/Pods/
+
+## Documentation cache and generated files:
+/.yardoc/
+/_yardoc/
+/doc/
+/rdoc/
+
+## Environment normalization:
+/.bundle/
+/vendor/bundle
+/lib/bundler/man/
+
+# for a library or gem, you might want to ignore these files since the code is
+# intended to run in multiple environments; otherwise, check them in:
+# Gemfile.lock
+# .ruby-version
+# .ruby-gemset
+
+# unless supporting rvm < 1.11.0 or doing something fancy, ignore this:
+.rvmrc
+
+# Used by RuboCop. Remote config files pulled in from inherit_from directive.
+# .rubocop-https?--*
diff --git a/options/gitignore/Rust b/options/gitignore/Rust
new file mode 100644
index 0000000..d01bd1a
--- /dev/null
+++ b/options/gitignore/Rust
@@ -0,0 +1,21 @@
+# Generated by Cargo
+# will have compiled files and executables
+debug/
+target/
+
+# Remove Cargo.lock from gitignore if creating an executable, leave it for libraries
+# More information here https://doc.rust-lang.org/cargo/guide/cargo-toml-vs-cargo-lock.html
+Cargo.lock
+
+# These are backup files generated by rustfmt
+**/*.rs.bk
+
+# MSVC Windows builds of rustc generate these, which store debugging information
+*.pdb
+
+# RustRover
+# JetBrains specific template is maintained in a separate JetBrains.gitignore that can
+# be found at https://github.com/github/gitignore/blob/main/Global/JetBrains.gitignore
+# and can be added to the global gitignore or merged into this file. For a more nuclear
+# option (not recommended) you can uncomment the following to ignore the entire idea folder.
+#.idea/ \ No newline at end of file