summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel@debian.org>2024-11-10 16:16:25 +0100
committerDaniel Baumann <daniel@debian.org>2024-11-10 16:16:25 +0100
commit91056da00ec6af3d739f55a52f12e267a8912f2c (patch)
tree784724ffbe7bcdda69f92b8b25799363558a7d7f
parentRemoving unused README.source. (diff)
downloadhaveged-91056da00ec6af3d739f55a52f12e267a8912f2c.tar.xz
haveged-91056da00ec6af3d739f55a52f12e267a8912f2c.zip
Removing sysvinit remains.
Signed-off-by: Daniel Baumann <daniel@debian.org>
-rw-r--r--debian/control2
-rw-r--r--debian/copyright5
-rw-r--r--debian/haveged.init.d100
3 files changed, 1 insertions, 106 deletions
diff --git a/debian/control b/debian/control
index aa991f9..bedc32e 100644
--- a/debian/control
+++ b/debian/control
@@ -13,7 +13,7 @@ Rules-Requires-Root: no
Package: haveged
Architecture: linux-any
Pre-Depends: ${misc:Pre-Depends}
-Depends: lsb-base (>= 3.2-14), ${shlibs:Depends}, ${misc:Depends}
+Depends: ${shlibs:Depends}, ${misc:Depends}
Suggests: apparmor
Description: Linux entropy source using the HAVEGE algorithm
haveged is a userspace entropy daemon which is not dependent upon the
diff --git a/debian/copyright b/debian/copyright
index 043ff0e..3bc3630 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -37,11 +37,6 @@ Copyright: 2009-2011 Gary Wuertz <gary@issiweb.com>
2011 BenEleventh Consulting <manolson@beneleventh.com>
License: GPL-3+
-Files: init.d/sysv.lsb init.d/sysv.redhat
-Copyright: 2011-2012 Gary Wuertz <gary@issiweb.com>
- 2011-2012 Jirka Hladky <hladky_dot_jiri_at_gmail_com>
-License: GPL-3+
-
Files: nist/dfft.c
Copyright: Public Domain
License: public-domain
diff --git a/debian/haveged.init.d b/debian/haveged.init.d
deleted file mode 100644
index e03a517..0000000
--- a/debian/haveged.init.d
+++ /dev/null
@@ -1,100 +0,0 @@
-#! /bin/sh
-### BEGIN INIT INFO
-# Provides: haveged
-# Required-Start: $remote_fs
-# Required-Stop: $remote_fs
-# Should-Start: $syslog
-# Should-Stop: $syslog
-# Default-Start: 2 3 4 5
-# Default-Stop: 0 1 6
-# Short-Description: Entropy daemon using the HAVEGE algorithm
-# Description: haveged uses HAVEGE (HArdware Volatile Entropy Gathering
-# and Expansion) to maintain a pool of random bytes used
-# to fill /dev/random whenever necessary.
-### END INIT INFO
-
-# Do NOT "set -e"
-
-PATH=/sbin:/usr/sbin:/bin:/usr/bin
-DESC="entropy daemon"
-NAME=haveged
-DAEMON=/usr/sbin/$NAME
-DAEMON_ARGS=""
-PIDFILE=/var/run/$NAME.pid
-SCRIPTNAME=/etc/init.d/$NAME
-
-# Exit if the package is not installed
-[ -x "$DAEMON" ] || exit 0
-
-# Read configuration variable file if it is present
-[ -r /etc/default/$NAME ] && . /etc/default/$NAME
-
-# Load the VERBOSE setting and other rcS variables
-. /lib/init/vars.sh
-
-# Define LSB log_* functions.
-. /lib/lsb/init-functions
-
-do_start()
-{
- start-stop-daemon --start --quiet --pidfile $PIDFILE --exec $DAEMON --test > /dev/null \
- || return 1
- start-stop-daemon --start --quiet --pidfile $PIDFILE --exec $DAEMON -- \
- $DAEMON_ARGS \
- || return 2
-}
-
-do_stop()
-{
- start-stop-daemon --stop --quiet --retry=TERM/30/KILL/5 --pidfile $PIDFILE --name $NAME
- RETVAL="$?"
- [ "$RETVAL" = 2 ] && return 2
- rm -f $PIDFILE
- return "$RETVAL"
-}
-
-case "$1" in
- start)
- [ "$VERBOSE" != no ] && log_daemon_msg "Starting $DESC" "$NAME"
- do_start
- case "$?" in
- 0|1) [ "$VERBOSE" != no ] && log_end_msg 0 ;;
- 2) [ "$VERBOSE" != no ] && log_end_msg 1 ;;
- esac
- ;;
- stop)
- [ "$VERBOSE" != no ] && log_daemon_msg "Stopping $DESC" "$NAME"
- do_stop
- case "$?" in
- 0|1) [ "$VERBOSE" != no ] && log_end_msg 0 ;;
- 2) [ "$VERBOSE" != no ] && log_end_msg 1 ;;
- esac
- ;;
- status)
- status_of_proc "$DAEMON" "$NAME" && exit 0 || exit $?
- ;;
- restart|force-reload)
- log_daemon_msg "Restarting $DESC" "$NAME"
- do_stop
- case "$?" in
- 0|1)
- do_start
- case "$?" in
- 0) log_end_msg 0 ;;
- 1) log_end_msg 1 ;; # Old process is still running
- *) log_end_msg 1 ;; # Failed to start
- esac
- ;;
- *)
- # Failed to stop
- log_end_msg 1
- ;;
- esac
- ;;
- *)
- echo "Usage: $SCRIPTNAME {start|stop|status|restart|force-reload}" >&2
- exit 3
- ;;
-esac
-
-: