summaryrefslogtreecommitdiffstats
path: root/contrib/build/build.sh
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/build/build.sh')
-rwxr-xr-xcontrib/build/build.sh38
1 files changed, 38 insertions, 0 deletions
diff --git a/contrib/build/build.sh b/contrib/build/build.sh
new file mode 100755
index 0000000..99a4b43
--- /dev/null
+++ b/contrib/build/build.sh
@@ -0,0 +1,38 @@
+#!/bin/sh
+##
+## Toggle between library and non-library builds. Fix messed up libtool environment
+## Build and run haveged-devel sample
+##
+case "$1" in
+nolib)
+ sed -i.bak -e '/^##libtool_start##/,/^##libtool_end##/s,^,##,g' ../../configure.ac
+ sed -i.bak -e '/^####nolibtool_start##/,/^####nolibtool_end##/s,^##,,g' \
+ -e '/^##libtool_start##/,/^##libtool_end##/s,^,##,g' ../../src/Makefile.am
+ cp nolib.spec ../../haveged.spec
+;;
+lib)
+ sed -i.bak -e '/^####libtool_start##/,/^####libtool_end##/s,^##,,g' ../../configure.ac
+ sed -i.bak -e '/^##nolibtool_start##/,/^##nolibtool_end##/s,^,##,g' \
+ -e '/^####libtool_start##/,/^####libtool_end##/s,^##,,g' ../../src/Makefile.am
+ cp lib.spec ../../haveged.spec
+;;
+new)
+ cd ../..
+ make distclean
+ rm -rf autom4te.cache
+ libtoolize --force --install
+ autoreconf --force
+ ./configure
+;;
+sample)
+ echo "gcc -o havege_sample -DUSE_SOURCE -I../../src -Wall havege_sample.c ../../src/.libs/libhavege.a"
+ gcc -o havege_sample -DUSE_SOURCE -I../../src -Wall havege_sample.c ../../src/.libs/libhavege.a
+ echo "./havege_sample > /dev/null"
+ ./havege_sample > /dev/null
+;;
+
+*)
+ echo "usage: build [new|nolib|lib|sample]";
+;;
+esac
+