summaryrefslogtreecommitdiffstats
path: root/Cargo.toml.orig
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml.orig')
-rw-r--r--Cargo.toml.orig30
1 files changed, 30 insertions, 0 deletions
diff --git a/Cargo.toml.orig b/Cargo.toml.orig
new file mode 100644
index 0000000..d8f4b9a
--- /dev/null
+++ b/Cargo.toml.orig
@@ -0,0 +1,30 @@
+[package]
+name = "sha256"
+version = "1.5.0"
+authors = ["baoyachi <liaoymxsdl@gmail.com>"]
+edition = "2018"
+description = "sha256 crypto digest"
+keywords = ["sha256", "hash", "digest"]
+readme = "README.md"
+categories = ["cryptography"]
+repository = "https://github.com/baoyachi/sha256-rs"
+license = "MIT OR Apache-2.0"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+hex = "0.4.2"
+sha2 = { version = "0.10.6", default-features = false }
+openssl = { version = "0.10.54", optional = true, default-features = false }
+async-trait = "0.1.68"
+tokio = { version = "1.28.2", optional = true, features = ["io-util", "fs"] }
+bytes = "1.4.0"
+
+[features]
+default = ["async"]
+native_openssl = ["openssl"]
+async = ["tokio"]
+
+[dev-dependencies]
+tokio = { version = "1.28.2", features = ["full"] }
+tokio-test = "0.4.2"