summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/cargo-checksum.json1
-rw-r--r--debian/changelog5
-rw-r--r--debian/control35
-rw-r--r--debian/copyright47
-rwxr-xr-xdebian/rules13
-rw-r--r--debian/source/format1
-rw-r--r--debian/tests/control23
-rw-r--r--debian/watch4
8 files changed, 129 insertions, 0 deletions
diff --git a/debian/cargo-checksum.json b/debian/cargo-checksum.json
new file mode 100644
index 0000000..4171720
--- /dev/null
+++ b/debian/cargo-checksum.json
@@ -0,0 +1 @@
+{"package":"b5097ec7ea7218135541ad96348f1441d0c616537dd4ed9c47205920c35d7d97","files":{}}
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..7611d0e
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+rust-soft-assert (0.1.1-1) unstable; urgency=low
+
+ * Initial upload to sid (build-depends of forgejo-api).
+
+ -- Daniel Baumann <daniel@debian.org> Wed, 20 Nov 2024 06:56:26 +0100
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..c49a813
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,35 @@
+Source: rust-soft-assert
+Section: rust
+Priority: optional
+Maintainer: Daniel Baumann <daniel.baumann@progress-linux.org>
+Build-Depends:
+ cargo:native <!nocheck>,
+ debhelper-compat (= 13),
+ dh-sequence-cargo,
+ libstd-rust-dev <!nocheck>,
+ rustc:native <!nocheck>,
+Rules-Requires-Root: no
+Standards-Version: 4.7.0
+Homepage: https://github.com/Cyborus04/soft_assert
+X-Cargo-Crate: soft_assert
+
+Package: librust-soft-assert-dev
+Section: rust
+Architecture: any
+Multi-Arch: same
+Depends:
+ ${misc:Depends},
+Provides:
+ librust-soft-assert+default-dev (= ${binary:Version}),
+ librust-soft-assert-0+default-dev (= ${binary:Version}),
+ librust-soft-assert-0-dev (= ${binary:Version}),
+ librust-soft-assert-0.1+default-dev (= ${binary:Version}),
+ librust-soft-assert-0.1-dev (= ${binary:Version}),
+ librust-soft-assert-0.1.1+default-dev (= ${binary:Version}),
+ librust-soft-assert-0.1.1-dev (= ${binary:Version}),
+Description: Non-panicking assertions - Rust source code
+ Various macros that return early if a given condition is false,
+ similar to the various `assert` macros in `std`
+ .
+ This package contains the source for the Rust soft_assert crate
+ for use with cargo and dh-cargo.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..9be6742
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,47 @@
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: soft_assert
+Upstream-Contact: https://github.com/Cyborus04/soft_assert/issues
+Source: https://github.com/Cyborus04/soft_assert
+
+Files: *
+Copyright: 2021 Cyborus <cyborus@cyborus.xyz>
+License: Apache-2.0 or MIT
+
+Files: debian/*
+Copyright: 2024 Daniel Baumann <daniel@debian.org>
+License: Apache-2.0 or MIT
+
+License: Apache-2.0
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+ .
+ https://www.apache.org/licenses/LICENSE-2.0
+ .
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+ .
+ The complete text of the Apache-2.0 License
+ can be found in /usr/share/common-licenses/Apache-2.0 file.
+
+License: MIT
+ Permission is hereby granted, free of charge, to any person obtaining a copy
+ of this software and associated documentation files (the "Software"), to deal
+ in the Software without restriction, including without limitation the rights
+ to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+ copies of the Software, and to permit persons to whom the Software is
+ furnished to do so, subject to the following conditions:
+ .
+ The above copyright notice and this permission notice shall be included in
+ all copies or substantial portions of the Software.
+ .
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+ IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+ AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+ LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+ THE SOFTWARE.
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..cd96ddb
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,13 @@
+#!/usr/bin/make -f
+%:
+ dh ${@} --buildsystem cargo
+
+override_dh_auto_test:
+ dh_auto_test -- test --all
+
+execute_after_dh_auto_install:
+ # removing unneeded files
+ rm -rf debian/librust-*/usr/share/cargo/registry/*/.git*
+ rm -f debian/librust-*/usr/share/cargo/registry/*/*.orig
+ rm -f debian/librust-*/usr/share/cargo/registry/*/*.MD
+ rm -f debian/librust-*/usr/share/cargo/registry/*/LICENSE*
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/tests/control b/debian/tests/control
new file mode 100644
index 0000000..8797d2f
--- /dev/null
+++ b/debian/tests/control
@@ -0,0 +1,23 @@
+Test-Command: /usr/share/cargo/bin/cargo-auto-test soft_assert 0.1.1 --all-targets --all-features
+Features: test-name=rust-soft-assert:@
+Depends:
+ dh-cargo (>= 31),
+ rustc,
+ @,
+Restrictions: allow-stderr, skip-not-installable
+
+Test-Command: /usr/share/cargo/bin/cargo-auto-test soft_assert 0.1.1 --all-targets
+Features: test-name=librust-soft-assert-dev:default
+Depends:
+ dh-cargo (>= 31),
+ rustc,
+ @,
+Restrictions: allow-stderr, skip-not-installable
+
+Test-Command: /usr/share/cargo/bin/cargo-auto-test soft_assert 0.1.1 --all-targets --no-default-features
+Features: test-name=librust-soft-assert-dev:
+Depends:
+ dh-cargo (>= 31),
+ rustc,
+ @,
+Restrictions: allow-stderr, skip-not-installable
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..ab6d18e
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,4 @@
+version=4
+opts=filenamemangle=s/.*\/(.*)\/download/soft_assert-$1\.tar\.gz/g,\
+uversionmangle=s/(\d)[_\.\-\+]?((RC|rc|pre|dev|beta|alpha)\.?\d*)$/$1~$2/ \
+https://qa.debian.org/cgi-bin/fakeupstream.cgi?upstream=crates.io/soft_assert .*/crates/soft_assert/@ANY_VERSION@/download