summaryrefslogtreecommitdiffstats
path: root/make-srpm.sh
diff options
context:
space:
mode:
authorDaniel Baumann <daniel@debian.org>2024-11-09 17:08:52 +0100
committerDaniel Baumann <daniel@debian.org>2024-11-09 17:08:52 +0100
commit7ae5754b6d5f4f5ce4c4894a9d0f7247731e4d29 (patch)
tree4d551ffc1d3e175c528c69f06e22a9ac2ac41854 /make-srpm.sh
parentInitial commit. (diff)
downloadceph-19-7ae5754b6d5f4f5ce4c4894a9d0f7247731e4d29.tar.xz
ceph-19-7ae5754b6d5f4f5ce4c4894a9d0f7247731e4d29.zip
Adding upstream version 19.2.0.upstream/19.2.0upstream
Signed-off-by: Daniel Baumann <daniel@debian.org>
Diffstat (limited to 'make-srpm.sh')
-rwxr-xr-xmake-srpm.sh11
1 files changed, 11 insertions, 0 deletions
diff --git a/make-srpm.sh b/make-srpm.sh
new file mode 100755
index 000000000..1ba0ff088
--- /dev/null
+++ b/make-srpm.sh
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+#
+# Create a SRPM which can be used to build Ceph
+#
+# ./make-srpm.sh <version>
+# rpmbuild --rebuild /tmp/ceph/ceph-<version>-0.el7.centos.src.rpm
+#
+
+./make-dist $1
+rpmbuild -D"_sourcedir `pwd`" -D"_specdir `pwd`" -D"_srcrpmdir `pwd`" -bs ceph.spec