summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml105
1 files changed, 105 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..4e90081
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,105 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "forgejo-api"
+version = "0.4.1"
+build = false
+autobins = false
+autoexamples = false
+autotests = false
+autobenches = false
+description = "Interface to Forgejo's Web API"
+readme = "README.md"
+license = "Apache-2.0 OR MIT"
+repository = "https://codeberg.org/Cyborus/forgejo-api"
+
+[lib]
+name = "forgejo_api"
+path = "src/lib.rs"
+
+[[test]]
+name = "admin"
+path = "tests/admin.rs"
+
+[[test]]
+name = "organization"
+path = "tests/organization.rs"
+
+[[test]]
+name = "repo"
+path = "tests/repo.rs"
+
+[[test]]
+name = "user"
+path = "tests/user.rs"
+
+[dependencies.base64ct]
+version = "1.6.0"
+
+[dependencies.bytes]
+version = "1.5.0"
+
+[dependencies.reqwest]
+version = "0.11.18"
+features = [
+ "json",
+ "multipart",
+]
+
+[dependencies.serde]
+version = "1.0.168"
+features = ["derive"]
+
+[dependencies.serde_json]
+version = "1.0.108"
+
+[dependencies.soft_assert]
+version = "0.1.1"
+
+[dependencies.thiserror]
+version = "1.0.43"
+
+[dependencies.time]
+version = "0.3.26"
+features = [
+ "parsing",
+ "serde",
+ "formatting",
+]
+
+[dependencies.tokio]
+version = "1.29.1"
+features = ["net"]
+
+[dependencies.url]
+version = "2.4.0"
+features = ["serde"]
+
+[dependencies.zeroize]
+version = "1.7.0"
+
+[dev-dependencies.eyre]
+version = "0.6.9"
+
+[dev-dependencies.reqwest]
+version = "0.11.18"
+features = ["cookies"]
+
+[dev-dependencies.tokio]
+version = "1.29.1"
+features = [
+ "net",
+ "fs",
+ "rt",
+ "macros",
+]