summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml13
1 files changed, 10 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 2095468..80a5dc3 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,8 +12,9 @@
[package]
edition = "2021"
name = "forgejo-cli"
-version = "0.1.1"
-build = false
+version = "0.2.0"
+build = "build.rs"
+autolib = false
autobins = false
autoexamples = false
autotests = false
@@ -42,6 +43,9 @@ version = "0.5.4"
version = "1.6.0"
features = ["std"]
+[dependencies.cfg-if]
+version = "1.0.0"
+
[dependencies.clap]
version = "4.5.11"
features = ["derive"]
@@ -59,7 +63,7 @@ version = "5.0.1"
version = "0.6.12"
[dependencies.forgejo-api]
-version = "0.4.1"
+version = "0.5.0"
[dependencies.futures]
version = "0.3.30"
@@ -121,5 +125,8 @@ version = "2.5.2"
version = "1.10.0"
features = ["v4"]
+[build-dependencies.git2]
+version = "0.19.0"
+
[features]
update-check = ["dep:semver"]