summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..b8163c8
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,27 @@
+[tool.poetry]
+package-mode = false
+
+[tool.poetry.dependencies]
+python = "^3.10"
+
+[tool.poetry.group.dev.dependencies]
+djlint = "1.35.2"
+yamllint = "1.35.1"
+codespell = "^2.2.6"
+
+[tool.djlint]
+profile="golang"
+ignore="H005,H006,H013,H016,H020,H021,H030,H031"
+
+[tool.codespell]
+skip = '.git,*.pdf,*.svg,package-lock.json,go.mod,locale,license,*.git,objects,*.fr-fr.*,*.de-de.*,*.css,go.sum,*.key,gitignore,pyproject.toml,diff_test.go,go-licenses.json,pyproject.toml,*.lock,venvs'
+# precise hits for CamelCased words,various other curious cases which require regex to ignore
+# entire line or some portion of it
+# TODO: Resolve Treshold typo in API and remove from here
+ignore-regex = '(\b(Treshold|mx claus|commitT|ReadBy|#afile|respOne|commitI|[cC]rossReference|SMove|reVer|CheckIn|NotIn)\b|shouldbe\.|women’s.*womens|"emoji":.*|,bu,|assert\.Equal.*"fo\b|github\.com/unknwon|Copyright 2014 Unknwon|allowed\.noone|[hH]eadErr|atLeast|{"\\U.*)|Iif|FilterIn|.*codespell-ignore.*'
+#|.*(Maskenpflicht|Geimpft),.*)'
+# te - TreeEntry variable
+# commiter - wrong spelling but seems used in API
+# ALLWAYS - is a config var
+# infact - other variable(s)
+ignore-words-list = 'bleve,crate,te,commiter,befores,allways,infact,startd,unknow'