summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel@debian.org>2024-11-17 07:28:39 +0100
committerDaniel Baumann <daniel@debian.org>2024-11-17 07:57:11 +0100
commita4d07f58763dc91de8a01ca35add1fe4243aae0b (patch)
tree9c3cd1511394c0e81585050cdd69074772c722f6
parentReleasing debian version 10.2-1. (diff)
downloadfrr-tmp-grpc.tar.xz
frr-tmp-grpc.zip
Building with grpc support by default, allow it to be excluded via pkg.frr.nogrpc build-profile.tmp-grpc
Signed-off-by: Daniel Baumann <daniel@debian.org>
-rw-r--r--debian/control5
-rwxr-xr-xdebian/rules7
2 files changed, 12 insertions, 0 deletions
diff --git a/debian/control b/debian/control
index 7bfc99dc..db2a13a5 100644
--- a/debian/control
+++ b/debian/control
@@ -16,11 +16,14 @@ Build-Depends:
libc-ares-dev,
libcap-dev,
libelf-dev:native,
+ libgrpc++-dev <!pkg.frr.nogrpc>,
+ libgrpc-dev <!pkg.frr.nogrpc>,
libjson-c-dev,
liblua5.3-dev <!pkg.frr.nolua>,
libpam0g-dev,
libpcre2-dev,
libprotobuf-c-dev,
+ libprotobuf-dev,
libpython3-dev:native,
libreadline-dev,
librtr-dev <!pkg.frr.nortrlib>,
@@ -31,6 +34,8 @@ Build-Depends:
lua5.3 <!pkg.frr.nolua>,
pkgconf,
protobuf-c-compiler,
+ protobuf-compiler <!pkg.frr.nogrpc>,
+ protobuf-compiler-grpc <!pkg.frr.nogrpc>,
python3-dev:native,
python3-pytest:native <!nocheck>,
python3-sphinx:native,
diff --git a/debian/rules b/debian/rules
index 25d2b05c..0da84b61 100755
--- a/debian/rules
+++ b/debian/rules
@@ -33,6 +33,12 @@ else
CONF_PIM6=--disable-pim6d
endif
+ifeq ($(filter pkg.frr.nogrpc,$(DEB_BUILD_PROFILES)),)
+ CONF_GRPC=--enable-grpc
+else
+ CONF_GRPC=--disable-grpc
+endif
+
export PYTHON=python3
%:
@@ -51,6 +57,7 @@ override_dh_auto_configure:
$(CONF_RPKI) \
$(CONF_LUA) \
$(CONF_PIM6) \
+ $(CONF_GRPC) \
--with-libpam \
--enable-doc \
--enable-doc-html \