summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel@debian.org>2024-11-10 16:16:28 +0100
committerDaniel Baumann <daniel@debian.org>2024-11-10 16:16:28 +0100
commit71d954994957f7666b519f5897961296b5f88b78 (patch)
treeb9cb470dbd315e5fe625da8428aa54a0a305d5a3
parentMoving apparmor files to local subdirectory within packaging directory. (diff)
downloadhaveged-71d954994957f7666b519f5897961296b5f88b78.tar.xz
haveged-71d954994957f7666b519f5897961296b5f88b78.zip
Wrap and sorting packaging files.
Signed-off-by: Daniel Baumann <daniel@debian.org>
-rw-r--r--debian/control62
-rw-r--r--debian/haveged-udeb.install2
-rw-r--r--debian/haveged.install3
-rw-r--r--debian/libhavege-dev.install2
-rw-r--r--debian/tests/control9
5 files changed, 48 insertions, 30 deletions
diff --git a/debian/control b/debian/control
index 8740e7a..36cedd5 100644
--- a/debian/control
+++ b/debian/control
@@ -2,8 +2,11 @@ Source: haveged
Section: misc
Priority: optional
Maintainer: Daniel Baumann <daniel@debian.org>
-Uploaders: nicoo <nicoo@debian.org>
-Build-Depends: debhelper-compat (= 13), dh-apparmor
+Uploaders:
+ nicoo <nicoo@debian.org>,
+Build-Depends:
+ debhelper-compat (= 13),
+ dh-apparmor,
Standards-Version: 4.7.0
Homepage: https://issihosts.com/haveged/
Rules-Requires-Root: no
@@ -11,9 +14,13 @@ Rules-Requires-Root: no
Package: haveged
Section: misc
Architecture: linux-any
-Pre-Depends: ${misc:Pre-Depends}
-Depends: ${shlibs:Depends}, ${misc:Depends}
-Suggests: apparmor
+Pre-Depends:
+ ${misc:Pre-Depends},
+Depends:
+ ${misc:Depends},
+ ${shlibs:Depends},
+Suggests:
+ apparmor,
Description: Linux entropy source using the HAVEGE algorithm
haveged is a userspace entropy daemon which is not dependent upon the
standard mechanisms for harvesting randomness for the system entropy
@@ -28,13 +35,24 @@ Description: Linux entropy source using the HAVEGE algorithm
More information about HAVEGE is available at
http://www.irisa.fr/caps/projects/hipsor/
-Package: libhavege2
-Section: libs
+Package: haveged-udeb
+Package-Type: udeb
+Section: debian-installer
+Architecture: linux-any
+Depends:
+ ${misc:Depends},
+ ${shlibs:Depends},
+Description: Linux entropy source using the HAVEGE algorithm -- udeb
+ This package is for use in the Debian Installer.
+
+Package: libhavege-dev
+Section: libdevel
Architecture: linux-any
Multi-Arch: same
-Depends: ${shlibs:Depends}, ${misc:Depends}
-Pre-Depends: ${misc:Pre-Depends}
-Description: entropy source using the HAVEGE algorithm - shared library
+Depends:
+ libhavege2 (= ${binary:Version}),
+ ${misc:Depends},
+Description: entropy source using the HAVEGE algorithm - development files
libhavege is a library that implements the HAVEGE (HArdware Volatile Entropy
Gathering and Expansion). It provides a random number generator and it's
associated tuning and testing factilities.
@@ -42,14 +60,18 @@ Description: entropy source using the HAVEGE algorithm - shared library
More information about HAVEGE is available at
http://www.irisa.fr/caps/projects/hipsor/
.
- This package contains the shared library.
+ This package contains the development files.
-Package: libhavege-dev
-Section: libdevel
+Package: libhavege2
+Section: libs
Architecture: linux-any
Multi-Arch: same
-Depends: libhavege2 (= ${binary:Version}), ${misc:Depends}
-Description: entropy source using the HAVEGE algorithm - development files
+Depends:
+ ${misc:Depends},
+ ${shlibs:Depends},
+Pre-Depends:
+ ${misc:Pre-Depends},
+Description: entropy source using the HAVEGE algorithm - shared library
libhavege is a library that implements the HAVEGE (HArdware Volatile Entropy
Gathering and Expansion). It provides a random number generator and it's
associated tuning and testing factilities.
@@ -57,12 +79,4 @@ Description: entropy source using the HAVEGE algorithm - development files
More information about HAVEGE is available at
http://www.irisa.fr/caps/projects/hipsor/
.
- This package contains the development files.
-
-Package: haveged-udeb
-Package-Type: udeb
-Section: debian-installer
-Architecture: linux-any
-Depends: ${shlibs:Depends}, ${misc:Depends}
-Description: Linux entropy source using the HAVEGE algorithm -- udeb
- This package is for use in the Debian Installer.
+ This package contains the shared library.
diff --git a/debian/haveged-udeb.install b/debian/haveged-udeb.install
index 6f6f644..c660a7e 100644
--- a/debian/haveged-udeb.install
+++ b/debian/haveged-udeb.install
@@ -1,2 +1,2 @@
-usr/sbin/haveged
usr/lib/*/libhavege.so.*
+usr/sbin/haveged
diff --git a/debian/haveged.install b/debian/haveged.install
index 4c801f4..63018d9 100644
--- a/debian/haveged.install
+++ b/debian/haveged.install
@@ -1,4 +1,3 @@
+debian/local/apparmor/* /etc/apparmor.d
usr/sbin/haveged
usr/share/man/man8/haveged.8
-
-debian/local/apparmor/* /etc/apparmor.d
diff --git a/debian/libhavege-dev.install b/debian/libhavege-dev.install
index 1e8eaeb..477ec99 100644
--- a/debian/libhavege-dev.install
+++ b/debian/libhavege-dev.install
@@ -1,4 +1,4 @@
-usr/share/man/man3/libhavege.3
usr/include/haveged/*.h
usr/lib/*/libhavege.a
usr/lib/*/libhavege.so
+usr/share/man/man3/libhavege.3
diff --git a/debian/tests/control b/debian/tests/control
index e948c86..cc5cfc0 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -2,8 +2,13 @@ Tests: check-service
Tests: run-tests
Restrictions: rw-build-tree, allow-stderr
-Depends: @builddeps@, @
+Depends:
+ @,
+ @builddeps@,
Tests: dieharder
Restrictions: skippable, allow-stderr
-Depends: @, grep, dieharder
+Depends:
+ dieharder,
+ grep,
+ @,