summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel@debian.org>2024-11-10 15:31:03 +0100
committerDaniel Baumann <daniel@debian.org>2024-11-10 15:31:03 +0100
commit2b16d0d8a6bead5bcc2125b890bf1a13d19602dc (patch)
treeb67952daab2d78e87c103ed10ece33ad6a9a2167 /src/Makefile.am
parentInitial commit. (diff)
downloadhaveged-2b16d0d8a6bead5bcc2125b890bf1a13d19602dc.tar.xz
haveged-2b16d0d8a6bead5bcc2125b890bf1a13d19602dc.zip
Adding upstream version 1.9.14.upstream/1.9.14
Signed-off-by: Daniel Baumann <daniel@debian.org>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..c507ea4
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,34 @@
+## Process this file with automake to produce Makefile.in.
+
+if ENABLE_BIN
+bin_PROGRAMS = haveged
+else
+sbin_PROGRAMS = haveged
+endif
+
+AM_CFLAGS=-Wall -Wextra -Wpedantic -I..
+
+####nolibtool_start##
+##haveged_SOURCES = haveged.c havege.c havegetune.c havegecollect.c havegetest.c havegecmd.c \
+## cpuid-43.h haveged.h havege.h havegetune.h havegecollect.h havegetest.h oneiteration.h \
+## havegecmd.h
+##
+##haveged_LDADD = @HA_LDFLAGS@
+####nolibtool_end##
+##libtool_start##
+lib_LTLIBRARIES = libhavege.la
+libhavege_la_CPPFLAGS =
+libhavege_la_LDFLAGS = -version-number @HAVEGE_LT_VERSION@
+libhavege_la_LIBADD = @HA_LDFLAGS@
+
+libhavege_la_SOURCES = havege.c havegetune.c havegecollect.c havegetest.c \
+ cpuid-43.h havege.h havegetune.h havegecollect.h havegetest.h oneiteration.h
+
+pkginclude_HEADERS = havege.h
+
+haveged_SOURCES = haveged.c haveged.h havegecmd.c havegecmd.h
+
+haveged_LDADD = @HA_LDFLAGS@ libhavege.la
+##libtool_end##
+
+MAINTAINERCLEANFILES = Makefile.in