summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel@debian.org>2024-11-20 22:55:37 +0100
committerDaniel Baumann <daniel@debian.org>2024-11-20 22:55:37 +0100
commit312d4fa92b23ab91bcec64e346cacaa0a6382547 (patch)
treeff38f2ddeebad1633e4b18407cde1f65ae1aafa7 /setup.py
parentInitial commit. (diff)
downloadpyfzf-upstream.tar.xz
pyfzf-upstream.zip
Adding upstream version 0.3.1.upstream/0.3.1upstream
Signed-off-by: Daniel Baumann <daniel@debian.org>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py61
1 files changed, 61 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..da96dee
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,61 @@
+#!/usr/bin/env python
+# coding: utf-8
+# Copyright (c) 2015 Nagarjuna Kumarappan
+#
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+# THE SOFTWARE.
+#
+# Author: Nagarjuna Kumarappan <nagarjuna.412@gmail.com>
+
+import os
+from setuptools import setup
+from distutils.command.install import INSTALL_SCHEMES
+
+for scheme in INSTALL_SCHEMES.values():
+ scheme['data'] = scheme['purelib']
+
+prjdir = os.path.dirname(__file__)
+
+def read(filename):
+ return open(os.path.join(prjdir, filename)).read()
+
+LONG_DESC = read('README.md') + '\nCHANGES\n=======\n\n' + read('CHANGES')
+
+setup(name='pyfzf',
+ include_package_data=True,
+ version=read('VERSION').strip('\n'),
+ description="Python wrapper for junegunn's fuzzyfinder (fzf)",
+ long_description=LONG_DESC,
+ author='Nagarjuna Kumarappan',
+ license='MIT',
+ author_email='nagarjuna.412@gmail.com',
+ url='https://github.com/nk412/pyfzf',
+ install_requires=[],
+ py_modules=['pyfzf'],
+ packages=['pyfzf'],
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'Environment :: Console',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: MIT License',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Topic :: Terminals'
+ ]
+ )
+