summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml60
1 files changed, 60 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..b8e3ccb
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,60 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "auth-git2"
+version = "0.5.5"
+authors = ["Maarten de Vries <maarten@de-vri.es>"]
+publish = ["crates-io"]
+description = "Authentication for `git2`"
+documentation = "https://docs.rs/auth-git2"
+readme = "README.md"
+keywords = [
+ "git",
+ "auth",
+ "credentials",
+ "git2",
+ "authentication",
+]
+categories = ["authentication"]
+license = "BSD-2-Clause"
+repository = "https://github.com/de-vri-es/auth-git2-rs"
+
+[dependencies.dirs]
+version = "5.0.1"
+
+[dependencies.git2]
+version = ">0.14, <20.0"
+default-features = false
+
+[dependencies.log]
+version = "0.4.19"
+optional = true
+
+[dependencies.terminal-prompt]
+version = "0.2.2"
+
+[dev-dependencies.assert2]
+version = "0.3.11"
+
+[dev-dependencies.clap]
+version = "4.3.21"
+features = ["derive"]
+
+[dev-dependencies.env_logger]
+version = "0.10.0"
+
+[dev-dependencies.git2]
+version = ">=0.14, <18.0"
+
+[features]
+log = ["dep:log"]