summaryrefslogtreecommitdiffstats
path: root/README.MD
diff options
context:
space:
mode:
authorDaniel Baumann <daniel@debian.org>2024-11-20 06:55:23 +0100
committerDaniel Baumann <daniel@debian.org>2024-11-20 06:55:23 +0100
commitef3db3079ea065cf9df4cbbcac995d546ca5613e (patch)
treecaeee98b4b9981506890992396a2d54d46042beb /README.MD
parentInitial commit. (diff)
downloadrust-soft-assert-ef3db3079ea065cf9df4cbbcac995d546ca5613e.tar.xz
rust-soft-assert-ef3db3079ea065cf9df4cbbcac995d546ca5613e.zip
Adding upstream version 0.1.1.upstream/0.1.1upstream
Signed-off-by: Daniel Baumann <daniel@debian.org>
Diffstat (limited to 'README.MD')
-rw-r--r--README.MD25
1 files changed, 25 insertions, 0 deletions
diff --git a/README.MD b/README.MD
new file mode 100644
index 0000000..02806c4
--- /dev/null
+++ b/README.MD
@@ -0,0 +1,25 @@
+# `soft_assert`
+
+Various macros that return early if a given condition is false.
+Similar to the various `assert` macros in `std`
+
+## Usage
+
+Add the following to your `Cargo.toml`:
+
+```toml
+[dependencies]
+soft_assert = "0.1"
+```
+
+## License
+
+This project is licensed under either of
+
+* [Apache License, Version 2.0](http://www.apache.org/licenses/LICENSE-2.0)
+ ([LICENSE-APACHE](LICENSE-APACHE))
+
+* [MIT License](http://opensource.org/licenses/MIT)
+ ([LICENSE-MIT](LICENSE-MIT))
+
+at your option.